Difference between revisions of "Installing Elance Tracker on 64bit GNU/Linux"

From Organic Design
Jump to: navigation, search
(onlyinclude)
(Change source-code blocks to standard format)
 
Line 8: Line 8:
 
== 32bit dependencies ==
 
== 32bit dependencies ==
 
Next after trying to run the Air installer again you may encounter a number of errors saying that various libraries are not found, even though you have them installed, such as ''libgtk2.0-0'', but the problem is, it's looking for the 32bit version of these things. The easiest way to satisfy all these 32bit dependencies is to use [https://wiki.debian.org/Multiarch/HOWTO Multiarch] and add the ''i386'' architecture, and then install the missing package and maybe some required dependencies, specifying the ''i386'' architecture for each.
 
Next after trying to run the Air installer again you may encounter a number of errors saying that various libraries are not found, even though you have them installed, such as ''libgtk2.0-0'', but the problem is, it's looking for the 32bit version of these things. The easiest way to satisfy all these 32bit dependencies is to use [https://wiki.debian.org/Multiarch/HOWTO Multiarch] and add the ''i386'' architecture, and then install the missing package and maybe some required dependencies, specifying the ''i386'' architecture for each.
{{code|<bash>
+
<source lang="bash">
 
sudo dpkg --add-architecture i386
 
sudo dpkg --add-architecture i386
 
sudo apt-get update
 
sudo apt-get update
 
sudo apt-get install libgtk2.0-0:i386
 
sudo apt-get install libgtk2.0-0:i386
</bash>}}
+
</source>
 
There may be a number of messages about needing to '''apt-get -f install''' to resolve dependency issues which you can just do as needed. After you have all these installed, you can then attempt to run the installer again.
 
There may be a number of messages about needing to '''apt-get -f install''' to resolve dependency issues which you can just do as needed. After you have all these installed, you can then attempt to run the installer again.
  
 
== Missing gnome-keyring or KWallet ==
 
== Missing gnome-keyring or KWallet ==
 
Eventually you should get a window come up with an agreement to agree to which looks positive, but you are then likely to get an error saying that the ''gnome-keyring'' or ''KWallet'' is needed to continue. This time it's not that it's looking for the ''i386'' version, but rather that it's looking in the wrong place. This can usually be fixed by locating it and creating a symlink into the base of ''/usr/lib'' where Air will spot it. Here's an example of finding and linking it:
 
Eventually you should get a window come up with an agreement to agree to which looks positive, but you are then likely to get an error saying that the ''gnome-keyring'' or ''KWallet'' is needed to continue. This time it's not that it's looking for the ''i386'' version, but rather that it's looking in the wrong place. This can usually be fixed by locating it and creating a symlink into the base of ''/usr/lib'' where Air will spot it. Here's an example of finding and linking it:
{{code|<bash>
+
<source lang="bash">
 
$ locate libgnome-keyring.so
 
$ locate libgnome-keyring.so
 
/usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0
 
/usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0
Line 23: Line 23:
  
 
$ sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 /usr/lib
 
$ sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 /usr/lib
</bash>}}
+
</source>
 
</onlyinclude>
 
</onlyinclude>
 
== Installing the Tracker ==
 
== Installing the Tracker ==
 
After Air is installed it should just be a simple matter of installing the Tracker.
 
After Air is installed it should just be a simple matter of installing the Tracker.
{{code|<bash>
+
<source lang="bash">
 
sudo dpkg -i Tracker.deb
 
sudo dpkg -i Tracker.deb
</bash>}}
+
</source>
 
[[Category:Linux]][[Category:Help]]
 
[[Category:Linux]][[Category:Help]]

Latest revision as of 18:11, 22 May 2015

To work on hourly-rate based jobs in Elance you need to install their Tracker tool so that your hours can be logged and reviewed for release of your weekly payments. Unfortunately the Tracker is built using Adobe Air which is no longer supported for GNU/Linux. Tracker only requires version 2.6 of Adobe Air which was the last version available for Linux and can still be downloaded from the archive, or directly from here.

Elance have instructions for Linux users to install Tracker here which works fine for 32bit Linux distros, but if you're running a 64bit distro, which most people these days are, then the installation process will be rather complicated (for example I completely broke Gnome trying to get it working! hopefully these instructions will help you avoid such issues). Problems will occur when trying to run the Air installer binary on a 64bit system, here's a list of the problems I've come across during installation on various 64bit GNU/Linux systems.

execvp: permission denied

If you get an error message saying execvp: permission denied, it most likely means that your /tmp directory is on a temporary filesystem which doesn't allow executable permissions. To fix this you can comment out the line in your /etc/fstab which mounts /tmp onto a tmpfs and reboot and it will then be part of the normal filesystem. You can uncomment this and reboot again after installation of Adobe Air is complete.

32bit dependencies

Next after trying to run the Air installer again you may encounter a number of errors saying that various libraries are not found, even though you have them installed, such as libgtk2.0-0, but the problem is, it's looking for the 32bit version of these things. The easiest way to satisfy all these 32bit dependencies is to use Multiarch and add the i386 architecture, and then install the missing package and maybe some required dependencies, specifying the i386 architecture for each.

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install libgtk2.0-0:i386

There may be a number of messages about needing to apt-get -f install to resolve dependency issues which you can just do as needed. After you have all these installed, you can then attempt to run the installer again.

Missing gnome-keyring or KWallet

Eventually you should get a window come up with an agreement to agree to which looks positive, but you are then likely to get an error saying that the gnome-keyring or KWallet is needed to continue. This time it's not that it's looking for the i386 version, but rather that it's looking in the wrong place. This can usually be fixed by locating it and creating a symlink into the base of /usr/lib where Air will spot it. Here's an example of finding and linking it:

$ locate libgnome-keyring.so
/usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0
/usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0.2.0

$ sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 /usr/lib

Installing the Tracker

After Air is installed it should just be a simple matter of installing the Tracker.

sudo dpkg -i Tracker.deb