Talk:Dell Inspiron 1525

From Organic Design

Ubuntu Install on 1525

This is for doing an install with availability of wired broadband, with an Inspiron 1525 hooked up to an external monitor, using Ubuntu workstation 8.04.1 LTS 64-bit

Preparation
  • Backup Evolution File --> Backup settings...
  • Backup home folder
  • Ensure wired access to router is possible
Procedure
  • Use latest Install ISO provided via Ubuntu download page
  • Reinstall Ubuntu
  • Plug into router via LAN cable, download updates and install updates
  • Add OD workstation package, download and install, see Category:Debian packages, although there was a permissions problem this time around
  • Copy Visible Home folders that were backed up into the Home directory
  • Add screenfix launcher to shortcut bar to solve HDMI to DVI problem, this links to the screenfix script
  • Copy backup folders into Home
.mozilla
.transmission
  • Run Evolution and use backed up data file to restore settings and data
  • Set up Transmission cron job
  • Install Skype and perform hack to deal with 64bit issues
  • Getting this msg while installing:
dpkg: skype: dependency problems, but configuring anyway as you request:
 skype depends on libqt4-core (>= 4.2.1); however:
  Package libqt4-core is not installed.
 skype depends on libqt4-gui (>= 4.2.1); however:
  Package libqt4-gui is not installed.
  • Using Synaptic to install liqt4 core and gui
Todo
  • Add backup process to cron
Questions
  • Possible to simplify Skype setup, or did i follow the wrong procedure?
I didn't get that trouble, maybe you installed it before the OD workstation package? --nad 00:44, 13 April 2009 (UTC)
That was the install before last. No trouble this time.--Milan 07:15, 13 April 2009 (UTC)
  • Possible to backup and restore task bar shortcuts?
  • Can I add the evolution backup to an automated backup procedure?
  • Why was there a permissions problem when trying to execute the add old packages procedure?
Suggestions
MediBuntu is already part of the Ubuntu Post Install which has not yet been added to the OD package, see the section on playing DVD's. --nad 15:07, 10 October 2008 (NZDT)
  • Alan suggested (& worked pretty well thus far) to create a separate EXT3 partition to host your /home directory, and another for your /var (this seems to be an area of primary concern, as it can fill up a partition & make your system unstable). /tmp maight be another candidate

This way, you can pop/scratch you system & get up & going fairly quickly. Solution's proven itself quite useful on my eeePC

  • There seems to be permissions inherent in 8.04 (been addressed in 8.04.1). Still numerous issues abound in Intrepid, bux fixes are coming out thick & fast

Reinstallation April 8, 2009

I had performed an upgrade from Ubuntu 8.04 to 8.10 which went well, however after a couple of months I lost sound so I decided to do a fresh install using the OS Factory Recovery 8.10 DVD ISO Dell OS Factory Recovery 8.10 ISO provided by Dell here, since it contains some Dell-specific modifications. This is the 32bit version of Ubuntu.

Preparation

  • Backup email files and settings using evolution export
  • Backup home folder

Completed

  • Install using DVD
  • Restore Evolution using backup file
  • Restore Firefox by copying data from backed up profile in home/.mozilla
  • Add od workstation to .sources list, download updates (ca. 300MB)
  • Download updates from dell-ubuntu package (ca. 370MB)
  • Import backed up music files into rhythmbox music player -easy
  • Install virtualbox, downloaded files from here
  • Import photos into F-spot
From here I followed the Ubuntu Post Install procedure
  • Add medibuntu to sources, update
    • Install Acrobat 8
    • Install Realplayer (for .rmvb files)
    • Install Google Earth
  • Install Skype, downloaded files from here
  • Upgraded to open office 3
  • Set up cron job for Transmission
  • Make vlc be the default media player
  • Sort out skype sound settings, still no go on using microphone and second audio jack
    • Used some advice from here:
I ve installed Ubuntu 8.10 about a week ago, and I was dealing with the mic jack problem ... there are forums threads that propose the alsa-base options 3stack, 5stack, 3stack-dell and auto .. but none of these works for me ...
Later, I also removed/purged pulseaudio, and i dont known if this step is part of the solution.

finally I found:

options snd-hda-intel model=dell-bios

I placed it in alsa-base, rebooted the system .. and works!

Also, the sound settings for microphone and skype have to be as follows:

Skype sound devices.png

Skype-Volume Control Preferences.png

  • Set up network printer and scanner shared off NAS - HP1315
    • Add hpaio to /etc/sane.d/dll.conf
sudo gedit /etc/sane.d/dll.conf
VBoxManage clonehd XP.vdi XPClone.vdi
  • The following procedure is used to work with cloned Virtualbox systems:
To clone a vdi file, in a console enter:
VBoxManage clonevdi vm1.vdi vm2.vdi
This will clone the original vm1 to make vm2 in the same location as vm1.
Install VBox on the destination machine and then copy the cloned vdi to the destination machine.
The location of the virtual machines and VDI files is important. They need to be in Virtualbox > file > preferences > general. You will need to set this up in VBox on your destination PC.
Then go Virtualbox > file > virtual disk manager" and use the "Add" button to add the new VM.
Start the process of creating a new VM. Virtualbox > new etc. When you get to the popup for "Virtual Hard Disk" you select "Existing" and select the clone VM you created. 
sudo remastersys dist milan-workstation-apr2009.iso

Lessons learned

  • Could not clone the virtualbox image that I used, seems like a bug.
  • Found out that transmission doesn't store .torrent files, so lost my incomplete downloads
    • Need to keep .torrent files in the download folder in a separate folder, these can then be imported again if transmission is reinstalled

Upgrade to Jaunty - May 5, 2009

After hearing about improved boot times and user interface enhancements, i decided to try the upgrade process.

Procedure

  • Back up home directory
  • Back up evolution settings using GUI tool
  • Select upgrade option via update manager
  • Downloaded ca. 1GB of files
  • Duration of download was about 45 mins
  • Duration of upgrade was about 1hr

Upgrade Problems

  • When the SAMBA setting dialogue box came up, the GUI froze irrecoverably
  • I was unable to log back in to the GUI to complete the upgrade
  • I hit ctrl+alt+F1 to get to the command line and entered:
  • apt-get dist-upgrade
  • Ubuntu responded by stating the process had been interrupted and gave the correct command to continue the upgrade
  • In the command line I was asked multiple time whether to keep or replace a range of settings.
  • I chose to keep, although Aran says it is best to choose replace with the maintainer's vbersion to avoid keeping legacy settings

Improvements

user@pc:~$ killall pulseaudio
user@pc:~$ sudo apt-get remove pulseaudio
user@pc:~$ sudo apt-get install esound
user@pc:~$ sudo rm /etc/X11/Xsession.d/70pulseaudio
  • Fonts and general interface looks much more polished

Persistent problems