Talk:Install a new server (CentOS)

From Organic Design

R error
configure: error: --with-x=yes (default) and X11 headers/libs are not available
Something to do with X11 --Sven 21:21, 3 Sep 2006 (NZST)

Wikiexpert Redhat version,

 $more /proc/version
 Linux version 2.4.20-021stab028.3.777-enterprise (st@current.eng.sw.ru) (gcc version 2.96 20000731 (Red Hat Linux 7.3 2.96-110)) #1 SMP Wed Feb 2
21:08:59 MSK 2005

A flavour of enterprise not fedora. On enterprise, there is a rpm manager that fetches rpm's directly from redhat, but I don't recommend using it. If you install something which interferes with Xwindows, then you have to do a rollback which is not easy to do without finding the offending rpm. This is not simple unless you have specifically archived all rpm's upgrades (which should be done routinely). --Sven 11:43, 3 Sep 2006 (NZST)


See Debian Post Install apache ssl certificate installation details --Sven 19:13, 29 Apr 2006 (NZST)


I changed the logging to debug to try and figure out this problem where it's not returning most of the non-php files properly (no error, but returns as zero-bytes). This debug log shows that a Function not implemented is happening.... but what'z it meeeeeen????

[Fri Apr 28 18:29:45 2006] [notice] SIGHUP received.  Attempting to restart
[Fri Apr 28 18:29:45 2006] [notice] Apache/2.2.0 (Unix) PHP/4.4.2 configured -- resuming normal operations
[Fri Apr 28 18:29:45 2006] [info] Server built: Mar 30 2006 03:27:54
[Fri Apr 28 18:29:45 2006] [debug] prefork.c(991): AcceptMutex: sysvsem (default: sysvsem)
[Fri Apr 28 18:31:02 2006] [info] [client 202.180.83.6] (38)Function not implemented: core_output_filter: writing data to the network

Problem solved! I googled the above error and found a solution which worked, setting

EnableSendFile off

in httpd.conf which was previously commented fixed it. --Nad 10:21, 3 May 2006 (NZST)

Glad to see its a configuration issue --Sven 14:12, 3 May 2006 (NZST)

Can't seem to create account, gif for robot detection doesn't show up--Phalseid 09:29, 28 Apr 2006 (NZST)

Don't do anything on that wikiexpert-OD-site yet (you could move div0 over if you like), because it's db will be replaced by the latest OD when I do the move... --Nad 10:31, 28 Apr 2006 (NZST)
Also - you don't need to sign up since you're already a user - its using the OD-wiki-db --Nad 12:46, 28 Apr 2006 (NZST)

http://www.wikiexpert.com/wiki now up and running (mediaWiki 1.4.15 default install)

  • removed old apache2/php/mysql rpm installations with
rpm -e --nodeps httpd-2.0.51-2.9.1.swsoft
rpm -e php-mysql-4.3.11-1.fc2.3.legacy.1.swsoft
rpm -e MySQL-client-standard-5.0.19-0.rhel4
rpm -e MySQL-server-standard-5.0.19-0.rhel4

I have not removed the other rpm dependencies of httpd-2.0.51-2.9.1.swsoft. Apache can be restarted with;

/usr/local/apache2/bin/apachectl restart # start | stop | restart etc

--Sven 18:39, 27 Apr 2006 (NZST)


Potential Server fix
  • The problem with the redhat install could be caused by using mysql5, we need to check the recommended installation dependencies and install them, this may require putting on mysql 4 instead.
  • For completeness we should also uninstall the rpm's that have been replaced by source installs for Apache, mysql, PHP etc
  • Configuration files for httpd.conf, and php.conf need checking aswell.

--Sven 08:30, 27 Apr 2006 (NZST)


Unfortunately you were right, there's still something wrong somewhere... I've run the config which all worked, it setup the db etc and made index.php a default for directory requests, but the main site still draws a blank (not even any http headers returned!?)... --Nad

I guess we first need to check the php.ini (/usr/local/lib from memory), and http.conf (/usr/local/apache2/conf) files. Maybe theres something in there. What about reinstalling a fresh version of MediaWiki 4.x.x? --Sven 10:14, 1 Apr 2006 (NZST)
All that stuff's totally normal - and how come the config/index.php was able to completely set up the db etc? I've just installed the same version on the new meridian server without a hitch...? --Nad 10:46, 1 Apr 2006 (NZST)
Also, downloaded 1.4.15 and installed that from scratch, install went perfectly, but then no wiki/index.php response!

Hmmm no domxml (see our current info.php), I'm seeing if it can be done from php.ini... Nad 12:29, 31 Mar 2006 (NZST)

Ok, that's working, it still needed to be pointed to the domxml.so in php.ini even though it was in the configure --Nad 12:43, 31 Mar 2006 (NZST)
I hope you added that to the article :p --Sven 15:14, 31 Mar 2006 (NZST)
Aw mate! I had to head out to do some LAN stuff over town (doing it now), but don't worry, I'll add those things (I can just copy from the debian post install) --Nad 16:57, 31 Mar 2006 (NZST)
We just need to make phpinfo.php (organicdesign) similar to phpinfo.php (wikiexpert). Should be able to add arguements to the php installation ./configure part, and just do a make, and make install over the top of the files already compiled --Sven 18:28, 31 Mar 2006 (NZST)

Ok, I'm copying last nights backup over to it now, and I'll install with that to check it out with latest code etc. We can just do another import and overwrite when we're ready for the real move later. --Nad 12:11, 31 Mar 2006 (NZST)


I'm pretty sure that --with-dom is usually --with-xml and --with-domxml...

Doesnt appear to be a --with-domxml switch (only dom)
[root@wikiexpert php-4.4.2]# ./configure --help | grep xml
  --with-dom[=DIR]        Include DOM support (requires libxml >= 2.4.14).
                          DIR is the libxml install directory.
  --disable-xml           Disable XML support using bundled expat lib
  --with-xmlrpc[=DIR]     Include XMLRPC-EPI support.
[root@wikiexpert php-4.4.2]# ./configure --help | grep dom
  --with-dom[=DIR]        Include DOM support (requires libxml >= 2.4.14).
  --with-dom-xslt[=DIR]     DOMXML: Include DOM XSLT support (requires libxslt >= 1.0.18).
  --with-dom-exslt[=DIR]    DOMXML: Include DOM EXSLT support (requires libxslt >= 1.0.18).
  --with-qtdom            Include QtDOM support (requires Qt >= 2.2.0).
PHP is currently compiled with:

./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql=/usr/local/mysql --with-ming --with-xml --with-domxml --with-zlib-dir=/usr/local/lib

If dom is not there, this may need to be

./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql=/usr/local/mysql --with-ming --with-dom --with-zlib-dir=/usr/local/lib