Talk:Peer.home

From Organic Design

This bouncy castle we call an internet service is wearing me down. DNS seems to be fucked; the name servers are not giving responses half the time. --Rob 23:55, 1 Jul 2006 (NZST)


Shell commands in c appear trivial. just tried the sandbox.c and it works fine. --Rob 23:29, 1 Jul 2006 (NZST)


Have removed rp script and moved that stuff to /etc/init.d/peerd. It's still giving these two errors:

kill 22372: No such process
kill 22437: No such process

Here is the init.d script:

+rp
Note the square brackets around the dot - that might fix the problem
That fixed it. Tested ok. --Rob 23:22, 1 Jul 2006 (NZST)

Perhaps we can use some existing wikisync stuff to sync a wiki version of this article into the init.d once it has been fixed. Or do it manually with vi.

Using embedded rp above, to sync - adding to Bender/fileSync

Telnet is working to the restarted peerd --Rob 23:02, 1 Jul 2006 (NZST)

Question: What will call /etc/init.d/peerd ? --Rob 23:06, 1 Jul 2006 (NZST)

The run-level symlinks in /etc/rc#.d run that, or the running peerd when it gets cmd over socket from user --Nad 23:14, 1 Jul 2006 (NZST)
So next step is to hard-wire a restart command into the socket c code --Rob 23:18, 1 Jul 2006 (NZST)